股票配资开户

同花顺反弹动能副图指标公式(附源码破译和源码)

         发布日期:2023-10-23 13:31    点击次数:129

编程思路破译

X_1赋值:(3*收盘价+开盘价+最低价+最高价)/6

X_2赋值:(20*X_1+19*1日前的X_1+18*2日前的X_1+17*3日前的X_1+16*4日前的X_1+15*5日前的X_1+14*6日前的X_1+13*7日前的X_1+12*8日前的X_1+11*9日前的X_1+10*10日前的X_1+9*11日前的X_1+8*12日前的X_1+7*13日前的X_1+6*14日前的X_1+5*15日前的X_1+4*16日前的X_1+3*17日前的X_1+2*18日前的X_1+20日前的X_1)/210

X_3赋值:X_2的5日简单移动平均

X_4赋值:(X_2-X_3)/收盘价*100

X_5赋值:X_4>1日前的X_4 AND 1日前的X_4<2日前的X_4 AND 2日前的X_4<3日前的X_4 AND X_4<0.01

X_6赋值:X_4>0.01 AND 1日前的X_4<0.01

X_7赋值:上次X_6>0距今天数

X_8赋值:统计X_7日中满足X_5>0的天数

输出小概率:1,画深灰色,线宽为2

输出中等概率:3,画淡蓝色,线宽为2

输出较高概率:4,画黄色,线宽为2

输出极高概率:5,画红色,线宽为2

当满足条件是否最后一个周期时,在1位置书写文字,画深灰色

当满足条件是否最后一个周期时,在2.8位置书写文字,画淡蓝色

当满足条件是否最后一个周期时,在3.8位置书写文字,画黄色

当满足条件是否最后一个周期时,在4.8位置书写文字,画红色

X_9赋值:1日前的最低价

X_10赋值:最低价-X_9的绝对值的3日[1日权重]移动平均/最低价-X_9和0的较大值的3日[1日权重]移动平均*100

X_11赋值:X_10*10的3日指数移动平均

X_12赋值:13日内最低价的最低值

X_13赋值:13日内X_11的最高值

X_14赋值:如果最低价<=X_12,返回(X_11+X_13*2)/2,否则返回0的3日指数移动平均/618

X_15赋值:如果如果X_14>500ANDX_8>0,返回500,否则返回X_14/10*X_8>10,返回如果X_14>500ANDX_8>0,返回500,否则返回X_14/10*X_8*5/100,否则返回如果X_14>500ANDX_8>0,返回500,否则返回X_14/10*X_8

当满足条件X_15>(-120)时,在0和X_15位置之间画柱状线,宽度为3,1不为0则画空心柱.,画深灰色

X_16赋值:成交量(手)/((最高价-最低价)*2-收盘价-开盘价的绝对值)

X_17赋值:X_15>=4 AND X_15<=5 AND X_15>X_8 AND X_8>=2

当满足条件X_17时,在0和X_15位置之间画柱状线,宽度为2.7,0不为0则画空心柱.,画黄色

X_18赋值:X_15>=5 AND X_15>X_8 AND X_8>=1

当满足条件X_18时,在0和X_15位置之间画柱状线,宽度为2.7,0不为0则画空心柱.,画红色

当满足条件X_8>=7时,在0和X_8*0.8位置之间画柱状线,宽度为3,1不为0则画空心柱.,画深灰色

当满足条件X_8>=7时,在0和X_8*0.8位置之间画柱状线,宽度为2.7,0不为0则画空心柱.,画红色

X_19赋值:X_15<=3 AND X_15>=0.5 AND X_8>=1 AND X_8<3 AND 收阳线ANDSE 开盘价/最低价-1>=0.01 OR (X_15>=4 AND X_8<3 AND X_15<=5)

当满足条件X_19时,在0和X_15位置之间画柱状线,宽度为2.7,0不为0则画空心柱.,画深灰色

X_20赋值:X_15<=4 AND X_15>=3 AND X_15>X_8 AND X_8>=2

当满足条件X_20时,在0和X_15位置之间画柱状线,宽度为2.7,0不为0则画空心柱.,画淡蓝色

输出反弹动能:统计X_7日中满足X_5>0的天数,画白色,线宽为2

程序源码

X_1:=(3*CLOSE+OPEN+LOW+HIGH)/6;

X_2:=(20*X_1+19*REF(X_1,1)+18*REF(X_1,2)+17*REF(X_1,3)+16*REF(X_1,4)+15*REF(X_1,5)+14*REF(X_1,6)+13*REF(X_1,7)+12*REF(X_1,8)+11*REF(X_1,9)+10*REF(X_1,10)+9*REF(X_1,11)+8*REF(X_1,12)+7*REF(X_1,13)+6*REF(X_1,14)+5*REF(X_1,15)+4*REF(X_1,16)+3*REF(X_1,17)+2*REF(X_1,18)+REF(X_1,20))/210;

X_3:=MA(X_2,5);

X_4:=(X_2-X_3)/CLOSE*100;

X_5:=X_4>REF(X_4,1) AND REF(X_4,1)<REF(X_4,2) AND REF(X_4,2)<REF(X_4,3) AND X_4<0.01;

X_6:=X_4>0.01 AND REF(X_4<0.01,1);

X_7:=BARSLAST(X_6>0);

X_8:=COUNT(X_5>0,X_7);

小概率:1,colorgray,LINETHICK2;

中等概率:3,colorliblue,LINETHICK2;

较高概率:4,coloryellow,LINETHICK2;

极高概率:5,colorred,LINETHICK2;

DRAWTEXT(ISLASTBAR,1,'海面'),colorgray;

DRAWTEXT(ISLASTBAR,2.8,'分界'),colorliblue;

DRAWTEXT(ISLASTBAR,3.8,'天际'),coloryellow;

DRAWTEXT(ISLASTBAR,4.8,'龙抬'),colorred;

X_9:=REF(LOW,1);

X_10:=SMA(ABS(LOW-X_9),3,1)/SMA(MAX(LOW-X_9,0),3,1)*100;

X_11:=EMA(X_10*10,3);

X_12:=LLV(LOW,13);

X_13:=HHV(X_11,13);

X_14:=EMA(IF(LOW<=X_12,(X_11+X_13*2)/2,0),3)/618;

X_15:=IF(IF(X_14>500 AND X_8>0,500,X_14)/10*X_8>10,IF(X_14>500 AND X_8>0,500,X_14)/10*X_8*5/100,IF(X_14>500 AND X_8>0,500,X_14)/10*X_8);

STICKLINE(X_15>(-120),0,X_15,3,1),colorgray;

X_16:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

X_17:=X_15>=4 AND X_15<=5 AND X_15>X_8 AND X_8>=2;

STICKLINE(X_17,0,X_15,2.7,0),coloryellow;

X_18:=X_15>=5 AND X_15>X_8 AND X_8>=1;

STICKLINE(X_18,0,X_15,2.7,0),colorred;

STICKLINE(X_8>=7,0,X_8*0.8,3,1),colorgray;

STICKLINE(X_8>=7,0,X_8*0.8,2.7,0),colorred;

X_19:=X_15<=3 AND X_15>=0.5 AND X_8>=1 AND X_8<3 AND CLOSE>OPEN AND OPEN/LOW-1>=0.01 OR (X_15>=4 AND X_8<3 AND X_15<=5);

STICKLINE(X_19,0,X_15,2.7,0),colorgray;

X_20:=X_15<=4 AND X_15>=3 AND X_15>X_8 AND X_8>=2;

STICKLINE(X_20,0,X_15,2.7,0),colorliblue;

反弹动能:COUNT(X_5>0,X_7),colorwhite,LINETHICK2;

注:

       馆内各种公式为学习编程而保存,实战使用前一定要看其中是否有未来函数并自己亲自测试成功率,决不能依据公式名称的描述和形容去投资,据此入市造成投资损失由投资者自己承担。

       发文不易,如获益,欢迎赞赏,赞赏必复!

本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报。

 
友情链接:

Powered by 股票配资开户_线上炒股配资平台_在线配资炒股服务平台 @2013-2022 RSS地图 HTML地图

Copyright 365站群 © 2014-2024 联华证券 版权所有