在线配资炒股服务平台

三警惕之二加仓选股指标公式(附源码破译和源码)

         发布日期:2023-10-23 13:59    点击次数:184

编程思路破译

GHCZS1赋值:收盘价的5日简单移动平均

GHCZS2赋值:收盘价的10日简单移动平均

GHCZS3赋值:收盘价的20日简单移动平均

GHCZS4赋值:收盘价的60日简单移动平均

GHCZS5赋值:GHCZS1-GHCZS2的绝对值+GHCZS2-GHCZS3的绝对值+GHCZS1-GHCZS3的绝对值

GHCZS6赋值:如果GHCZS5/收盘价<6/100,返回2,否则返回0

GHCZS7赋值:成交量(手)/1日前的成交量(手)的5日简单移动平均

GHCZS8赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均

GHCZS9赋值:GHCZS8的9日指数移动平均

MACD赋值:2*(GHCZS8-GHCZS9)

CZS1赋值:如果GHCZS8上穿GHCZS9ANDMACD>1日前的MACD,返回1,否则返回0

CZS2赋值:如果GHCZS8上穿GHCZS9ANDGHCZS8<0ANDGHCZS9<0ANDMACD>1日前的MACD,返回1,否则返回0

CZS3赋值:如果

GHCZS8>0ANDGHCZS9>0ANDCROSS(GHCZS8,GHCZS9)ANDMACD>1日前的MACD,返回1,否则返回0

CZS4赋值:如果成交量(手)<1日前的150日内成交量(手)的最低值,返回1.5,否则返回0

CZS5赋值:如果成交量(手)<1日前的120日内成交量(手)的最低值,返回1.2,否则返回0

CZS6赋值:如果成交量(手)<1日前的90日内成交量(手)的最低值,返回0.9,否则返回0

CZS7赋值:如果成交量(手)<1日前的60日内成交量(手)的最低值,返回0.6,否则返回0

CZS8赋值:如果成交量(手)<1日前的40日内成交量(手)的最低值,返回0.4,否则返回0

CZS9赋值:如果CZS2=1ANDREF(最近40日存在CZS2=1,12)AND(GHCZS9>12日前的GHCZS9ORGHCZS9>13日前的GHCZS9ORGHCZS9>14日前的GHCZS9ORGHCZS9>15日前的GHCZS9ORGHCZS9>16日前的GHCZS9ORGHCZS9>,返回EF(GHCZS9,17)ORGHCZS9>18日前的GHCZS9ORGHCZS9>19日前的GHCZS9ORGHCZS9>20日前的GHCZS9ORGHCZS9>21日前的GHCZS9ORGHCZS9>22日前的GHCZS9ORGHCZS9>23日前的GHCZS9ORGHCZS9,否则返回24日前的

GHCZS9ORGHCZS9>25日前的GHCZS9ORGHCZS9>26日前的GHCZS9)

CZS10赋值:如果(最近12日存在CZS4=1.5OREXIST(CZS5=1.2,12)OREXIST(CZS6=0.9,12))ANDCZS1,返回1,否则返回0

CZS11赋值:如果(最近12日存在CZS4=1.5OREXIST(CZS5=1.2,12)OREXIST(CZS6=0.9,12))ANDCZS1,返回1,否则返回0

CZS12赋值:如果(最近10日存在CZS5=1.2OREXIST(CZS6=0.9,10)OREXIST(CZS7=0.6,10)OREXIST(CZS8=0.4,10))ANDCZS1,返回1,否则返回0

输出二加仓:CZS11 AND 收盘价<GHCZS4*1.2 AND GHCZS7>2.2,画红色

程序源码

GHCZS1:=MA(C,5);

GHCZS2:=MA(C,10);

GHCZS3:=MA(C,20);

GHCZS4:=MA(C,60);

GHCZS5:=Abs(GHCZS1-GHCZS2)+ABS(GHCZS2-GHCZS3)+ABS(GHCZS1-GHCZS3);

GHCZS6:=IF(GHCZS5/C<6/100,2,0);

GHCZS7:=vol/REF(MA(VOL,5),1);

GHCZS8:=EMA(CLOSE,12)-EMA(CLOSE,26);

GHCZS9:=EMA(GHCZS8,9);macd:=2*(GHCZS8-GHCZS9);

CZS1:=IF(crOSS(GHCZS8,GHCZS9) AND MacD>REF(MACD,1),1,0);

CZS2:=IF(CROSS(GHCZS8,GHCZS9) AND GHCZS8<0 AND GHCZS9<0 AND MACD>REF(MACD,1),1,0);

CZS3:=IF(GHCZS8>0 AND GHCZS9>0 AND CROSS(GHCZS8,GHCZS9) AND MACD>REF(MACD,1),1,0);

CZS4:=IF(VOL<REF(LLV(VOL,150),1),1.5,0);

CZS5:=IF(VOL<REF(LLV(VOL,120),1),1.2,0);

CZS6:=IF(VOL<REF(LLV(VOL,90),1),0.9,0);

CZS7:=IF(VOL<REF(LLV(VOL,60),1),0.6,0);

CZS8:=IF(VOL<REF(LLV(VOL,40),1),0.4,0);

CZS9:=IF(CZS2=1 AND REF(EXIST(CZS2=1,40),12) AND (GHCZS9>REF(GHCZS9,12) OR GHCZS9>REF(GHCZS9,13) OR GHCZS9>REF(GHCZS9,14) OR GHCZS9>REF(GHCZS9,15) OR GHCZS9>REF(GHCZS9,16) OR GHCZS9>REF(GHCZS9,17) OR GHCZS9>REF(GHCZS9,18) OR GHCZS9>REF(GHCZS9,19) OR GHCZS9>REF(GHCZS9,20) OR GHCZS9>REF(GHCZS9,21) OR GHCZS9>REF(GHCZS9,22) OR GHCZS9>REF(GHCZS9,23) OR GHCZS9>REF(GHCZS9,24) OR GHCZS9>REF(GHCZS9,25) OR GHCZS9>REF(GHCZS9,26)),1,0);

CZS10:=IF((EXIST(CZS4=1.5,12) OR EXIST(CZS5=1.2,12) OR EXIST(CZS6=0.9,12)) AND CZS1,1,0);

CZS11:=IF((EXIST(CZS4=1.5,12) OR EXIST(CZS5=1.2,12) OR EXIST(CZS6=0.9,12)) AND CZS1,1,0);

CZS12:=IF((EXIST(CZS5=1.2,10) OR EXIST(CZS6=0.9,10) OR EXIST(CZS7=0.6,10) OR EXIST(CZS8=0.4,10)) AND CZS1,1,0);

二加仓:CZS11 AND C<GHCZS4*1.2 AND GHCZS7>2.2,COLORRED;

注:

       馆内各种公式为学习编程而保存,实战使用前一定要看其中是否有未来函数并自己亲自测试成功率,决不能依据公式名称的描述和形容去投资,据此入市造成投资损失由投资者自己承担。

       发文不易,如获益,欢迎赞赏,赞赏必复!

本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报。

 
友情链接:

Powered by 股票配资开户_线上炒股配资平台_在线配资炒股服务平台 @2013-2022 RSS地图 HTML地图

Copyright 365站群 © 2014-2024 联华证券 版权所有